Turn Signals

Specifically for ram-air triple freaks

Turn Signals

Postby skydrol » Wed Apr 11, 2012 5:13 pm

First, It is very sad that the last post on this forum is from me, almost a year ago!!

That being said, wondering if anyone has had trouble with their turn signals? Riding to work the other morning in the dark I noticed all 4 turn signals coming on at once. Sometimes bright, sometimes just glowing a little, and then they would go out for a while, then do it some more.
When I got the bike it had 1703 bulbs in the turn signals so that's what I've been running. Did a check on voltage regulator and found output just a little high and did the adjustment. I haven't ridden since but with it idling I didn't notice any problems.
I haven't checked for shorting yet, that will be the next step if the voltage regulation doesn't help.
Any other thoughts on the subject that I might have missed?
Rom10:9
skydrol
 
Posts: 29
Joined: Sun Jul 05, 2009 4:24 pm

Re: Turn Signals

Postby oldjapanesebikes » Wed Apr 11, 2012 7:32 pm

You don't mention the model or year of the bike, but it sounds like a short somewhere. I'd check the grounds/earths first, then I would pull the connector on the signal flasher and make sure those connections were clean and shiny. Then I would look at the left handle switch. 8-)
_________________
Ian

1966 Yamaha YA6
1968 Suzuki T500 (current project)
1972 Suzuki GT750 (future project)
1973 Suzuki GT750
1975 Suzuki GT/GS750 Custom
1976 Suzuki GT750 - Blue
1976 Suzuki GT750 - Red
1977 Suzuki GT500
User avatar
oldjapanesebikes
 
Posts: 95
Joined: Mon Feb 16, 2009 5:16 pm
Location: Alberta, Canada

Re: Turn Signals

Postby skydrol » Thu Apr 12, 2012 4:29 pm

this is on my '74 550. Thanks, will do.
Rom10:9
skydrol
 
Posts: 29
Joined: Sun Jul 05, 2009 4:24 pm


Return to GT380/550 triple specific

Who is online

Users browsing this forum: No registered users and 1 guest

cron